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Setting up DSP Starter Kit (DSK)

1. Begin by downloading the latest Code Composer Studio (CCS) software from the following link:
http://processors.wiki.ti.com/index.php/Download CCS
a. CCSv3.1isavailable on the CD with the product but this does NOT support Windows
Vista and higher operating systems. You must use a later version of CCS for these OSes.
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Download CCS

Contents [hide

2. After the executable is finished downloading, double-click it to run. A window will open up and
check the status of your system. If there is any errors or warnings in the textbox, it is
recommended you resolve those issues before continuing


http://processors.wiki.ti.com/index.php/Download_CCS

&¥ Code Composer Studio v7 Setup — O x
CC5 Installation

The Code Compaoser Studio installer is checking for any preinstall dependencies. This may take some time,

Please read the information carefully to determine if you need to take any action prior to
continuing.

Starting dependency checks...

Operating Systern Check: Windows 10 -» QK

Unicode character Check -> 0K

Anti-Virus Check -> We have detected you are running anti-virus software on this computer. To ensure no problems occur during the installation, it
is highly recommended that real-time file scanning be turned off before proceeding with the installation,

Pending reboot Check -» COK

Checking Windows Updates...

Done
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3. Accept the terms and conditions and continue
4. Select the desired installation folder for CCS and continue
a. Ifunsure, leave the default folder and continue



n‘r
Choose Installation Location

Where should Code Composer Studio v7 be installed?

To change the main installation folder click the Browse butten,

CCS Install Folder

chti ~ Browse

Texas Instrurnents

< Back Mext = Finish Cancel

5. Select the Product Families to be installed. For this DSP Starter Kit, the processor is C6000
Power-Optimized DSP. Press “Next” to continue



Processor Support

Select Product Families to be installed,

Description

O MSP430 ultra-low power MCUs e The S
. —_— - e CB000 category includes a
O Simplelink™ MSP432™ low power + performance MClUs number of DSP farmilies: CBAx. CET4x

O SimpleLink™ CC13x and CC260 Wireless MCUs and Co4x
O SimpleLink™ Wi-Fi® CC32w¢ Wireless MCUs

[0 CC2538 IEEE 802.15.45 Wireless MCUs

O C2000 real-time MCUs

O TM4C12x ARM® Cortex® -M4F core-based MCUs

O Hercules™ Safety MCUs

O Sitara™ AN Processors

O OMAP-L1x DSP + ARM3® Processor

O DaVinci (DM) Video Processors

[0 OMAP Processors

OO TDAx Driver Assistance SoCs & Jacinto DRAx Infotainment SoCs

O C55% ultra-low-power DSP

O 664K2x multicore DSP + ARM® Processors & CHfx KeyStone™ multicore DSP
O mmWave Sensors

O C64x multicore DSP

O UCD Digital Power Controllers

O PGA Sensor Signal Conditioners

[]Select All Install Size: 958.92 MB.
Download Size: 319.64 MB.

Texas Instruments

< Back MNext = Finish Cancel

6. Select the Spectrum Digital Debug Probes and Boards option and click Finish
a. This option installs the drivers required to program to the board



&¥ Code Composer Studio
Select Debug Probes

Select the debug probes you want installed and deselect the debug probes you want to leave out.

Description

TI XDS5 Debug Probe Support
O Blackhawk Debug Probes
Spectrum Digital Debug Probes and Boards

Drivers and support files for Spectrum
Digital J)TAG debug probes and
development boards.

[ |Select All Install Size: 1169.97 MB.
Download Size: 389.9% MB.

Texas Instruments

= Back Mext > Cancel

7. CCS will now be downloaded and installed. When finished, you will see a window like the
following. Click Finish and CCS is successfully installed!



& Code Composer Studio v7 Setup — O >
CCS Installation

Code Composer Studic has been successfully installed.

[#]Launch Cade Composer Studio
Create Desktop Shortcut
Create Start Menu Shortcut

Texas Instruments

8. Start CCS. Upon first startup, a dialog will appear asking where your workspace directory should
be located. The default location is fine but check Use this as the default and do not ask again
and press OK.



«« Eclipse Launcher ot
Select a directory as workspace
Code Composer Studio uses the workspace directery to store its preferences and development artifacts.
Workspace: | ChUsers\adellic\workspace v7 w Browse...
se this as the default and do not ask again
9. Next, we need to install any necessary updates. Go to Help->Check for Updates
10. Install any necessary updates. Typically, the C6000 device support will need to be updated
Available Updates P
(.
Check the updates that you wish to install, b J).‘...;
Name Version Id
{1 4 CH000 device support 1.14 com.ti.cestudio.c6000.devicesupport.win...
(71 Emulators 7.043.0 com.ti.emulation.pack.win32.feature.gro...
Select All Deselect All
Details
f:?;' < Back MNext = Finizsh Cancel

11. Next, we must install the C6000 compile. Select View->CCS App Center
12. In the section “Code Composer Studio Add-ons”, select C6000 Compiler (v7) and then select

Install Software at the top of the page

a. The C6000 Compiler v8 and above does NOT support this board anymore since it is so
old. You must use v7 of the compiler!
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App Center

2 Texas Instruments

L& install Software Q Relevance | v

Code Composer Studio Add-ons

For TI-RTOS and other software packages please use Resource Explorer

C6000 Compiler (v8) C6000 Compiler (v7) EVE Compiler C5500 Compiler Mylyn
Texas Instruments Texas Inst ents Texas Instruments Texas Instruments Eclipse Foundatio
(0 Soiect_ 2 Selecw (@ Soiec | (8 Soiect_

13. Accept the terms of agreement, and follow the prompt to finish the installation. Restart CCS to

have the changes take effect

14. The software side of things is complete for installation. Now we move on to the hardware. Plug
in the +5V power supply to the DSK board. When power is applied to the board the Power On
Self Test (POST) will run. LEDs 0-3 will flash. When the POST is complete all LEDs blink on and off

then stay on. At this point your DSK is functional.



15.

16.

At this point, your DSK is functional and you can connect it to your PC with the included USB
cord.
a. You should hear the familiar “beep” noise when plugging in the USB. If not, this may be
an issue.
You are finished setting up your DSK board. The next steps are to create a project and compile
and run it on the board.

Creating Project in CCS

To begin creating a new project in CCS, start by selecting File->New->CCS Project
a. You can also select File->New->Project and then select CCS Project but this is an extra
step
A new project dialog box will appear. Fill in the following settings:
a. Target: TMS320C6713
b. Connection: Spectrum Digital DSK-EVM-eZdsp onboard USB Emulator
c. Project Name: Your desired project name
d. Compiler Version: Tl V7.4.23 (version downloaded from CCS App Center)



“+ Mew CCS Project O *

CCS Project _—5
Create a new CCS Project. i i

Target: <select or type filter text> ~ || TM5320C6713 ~

Connection: | Spectrum Digital DSK-EVM-eZdsp enbeard USE Emulater ~ Verify...

= CETXX [CB000]

Project name: | SimpleExample

[+] Use default location
ChUsers\adellio\workspace_vn\SimpleExample Browse...

Compiler version: | Tl v7.4.23 ~ More...

b Advanced settings
w Project templates and examples

type filter tesxt Creates an empty project fully initialized for
the selected device. The project will contain

v [i=] Empty Projects an empty 'main.c’ source-file,

= Empty Project
= Empty Project (with main.c)
= Empty Assembly-only Project
= Empty RTSC Project

w || Basic Examples
= Hello Werld

Open Rescurce Explorer to browse a wide selection of example projects...

'/?3' < Back Mext = Cancel

3. Select “Finish” to create the project. A new window will appear where you will spend most of
your time programming. Make sure you have the “Project Explorer” panel on the left hand side.
If not, you can show it by selecting View->Project Explorer
4. This next step is a one-time thing. If this has already been completed, then you may move on to
the next step. Extract the provided folders include and lib folders to
C:\ti\ccsv7\tools\compiler\c6000_7.4.23. There should already be existing include and lib
folders in this directory
a. These files are used to communicate with the board. They are specific to the board with
functions such as read from Audio Codec, read state of switch, or change the state of
the LEDs
b. The provided directory will depend on where you installed your CCS installation. Please
adjust accordingly



« v P » ThisPC » OSDisk(C:) » ti » ccsv? » tools » compiler » c6000_7.4.23

5sh Ced Mame Date modified T
~ IndependentStu bin 8/25/20017T 116 AM F
InstallingCodeCi doc 8/25/2017 10:16 AM  F
J‘s Music include 8/25/2017 10:57T AM  F
) ) lib 8/25/2017 1:58 AM  F

& OneDrive for Busi o .
man 8/25/2017 10:16 AM  F
E} SharePaint prelink 8/25/2M7 1016 AM F
'&- C6000_7.4x_CodeGenerationTools_Manif... 8/18/2017 434 PM C

3 This PC o

'&- Closed_defects.html 8/18/2017 4:34 PM C
& A360 Drive =] LICENSE.bet 8/18/2017435PM T
I Desktop =] misra.bt B/18/2017 434PM T
[£ Decuments € Open_defects.html 8/18/2017 434PM  C
; Downloads |_'| README. bet 8/18/2017 4:34 PM T

5. Now we need to link the library files that contain the actual source code for the support library
functions. In the Project Explorer, right-click your project name and select Show Build Settings

6. A new dialog will appear. Select CCS Build->C6000 Linker->File Search Path in the list on the left
hand side. Under the first textbox, select the paper icon with the green plus to add a new
library. Type in dsk6713bsl.lib and select OK

B¢ Properties for SimpleExample O

type filter test File Search Path =1 v
General

w Build
v CB000 Compiler Configuration: |Debug [ Active | ~ | | Manage Configurations...

Processor Options
Optimization

Debug Options -
Include Options Include library file or command file as input (--library, -1} D & Tl
"libc.a"

dsk6713bsl.lib

Performance Advisor

Advanced Options
~ (CB000 Linker

Basic Options

File Search Path v+ Add file path *
Advanced Options
C6000 Hex Litility [Disabled] File:

~ | dsk6713bsllib |
Add <dir> to library sea

"$CG_TOOL_ROOTY ik Workspace... Variables... Browse...
"§/CG_TOOL_ROOTYinc

[]5earch libraries in priority order (--priarity, -priority)
Reread libraries; resolve backward references (--reread_libs, -x)
[] Disable automatic RTS selection (--disable_auto_rts)

@ Show advanced settings Cancel

7. Repeat Step 7 to add another library named ¢sl6713.lib



a. Repeat Step 7 and Step 8 for the Release configuration by selecting the combo box at
the top and changing it from Debug to Release
8. Press OK again to exit the build settings and open the file TMS320C6713.ccxml (it may also be
located in the directory targetConfigs). Select the Advanced tab at the bottom of the page.
Select TMS320671X in the connections tree view. Finally, set the initialization script under Cpu
Properties to the GEL script (DSK6713.gel) provided.
a. The GEL script contains to flush the cache, reset the board, and other things that are not
absolutely required to build your project. However, one issue that arises without the

GEL script is running your project on the board requires you to power cycle the board
each time.

¥ workspace_v7 - CCS Edit - HelloWorld/targetConfigs/TMS320C6713.com - Code Composer Studio
File Edit View Navigate Project Run Scripts Window Help
B4~ Hvifw x e

Getting Started  [d mainc [ *TMS320C6713.coxml 31

Target Configuration

All Ca

tions Cpu Properties
v %, Spectrum Digital DSK-EVM-eZdsp onboard US8 Emulator I C67IxCRU
~ @ TMS320C6713

@ TMS3200671X New. Set the properties of the sefected cpu

ey

alization script |\ \.\Desktop\DSK6713 gel e

1g mainc [slave Processor

= [ml #1 Problems
No consoles ta display at this time. 0 errars, 3 wamings, 0 others

9. Press OK again to exit the build settings and open the file main.c from the Project Explorer. This
should be familiar to you since this is where the C code will be at. As an initial test, copy/paste
the code below into the file

a. The CHIP_6713 macro is required for EVERY project to let the library know what board
this is for.

b. The three include files are also necessary to import the functions dsk6713 XXX
In future projects, don’t forget to call dsk6713_init() and supplementary init’s or the
program will not work correctly

d. Inthis example, LED 2 (they are labelled on the board) will toggle on/off at a rate of 1Hz



/*
* main.c
*/
#tdefine CHIP_ 6713

#include "dsk6713.h"
#include "dsk6713 led.h"
#include "dsk6713_flash.h"

void main(void)

{
DSK6713_init();
DSK6713_LED_init();

while (1)

{
DSK6713_LED_toggle(2);
DSK6713_waitusec(1000000);

10. Press the hammer icon to build the source code into a binary with extension .out. You will know
it built correctly if the two panels at the bottom Console and Problems show that no errors
occurred

a. If you get an “undefined reference...” error, that means you made a mistake with linking
the .lib file

b. If you get an “cannot find some include .h file” error, that means you may have
forgotten to copy the include files into the correct directory

B Consale 52 8 4|5 AR | MBS = 8 [# Poblems 12 v =78
CDT Build Console [SimpleExample] 0 errors, 2 warnings, 0 others

SIf SUNPLECAGNpLE . Map - -[Edp_SIZE=UXews ~I Ui/ (L7 CCSV/7 LOULS/ CURPLIET] COuow 7. %. 237 LID " =
-i"C:/tifccsv7/tools/compiler/c6088_7.4.23/include” --reread_libs --display_error_number
--warn_sections --diag_wrap=off --xml_link_info="SimpleExample_linkInfo.xml" --rom_model -o b Warmings (2 items)
"SimpleExample.out” "./main.cbj™ "../C6713.cmd"™ -1libe.a -1dsk6713bsl.1lib -1dsk&713bsl.lib

<Linking>

warning #16082-D: build attribute vendor section TI missing in

“C:/ti/cecsvi/tools/compiler/c600@ 7.4.23/1ib/dsk6713bs1.1ib<dsk6713.0bj>": compatibility

cannot be determined

warning #16@@2-D: build attribute vendor section TI missing in
"C:/ti/ccsv7/tools/compiler/c6@0@_7.4.23/1ib/dsk6713bs1.1ib<dsk6713_led.obj>":

compatibility cannot be determined

"Finished building target: SimpleExample.out’

Description Resource

**%% Build Finished ***=

11. Finally, we will upload the binary to the board and run the code. Select Run->Debug or press F11
a. CCS will change from edit mode to run mode.
b. Inthe Debug panel, you should see the emulator name with the following in
parenthesis: (Suspended — SW Breakpoint). This means the binary was successfully
uploaded and it is waiting to run.



File Edit View Project Tools Run  Scripts  Window Help
9 - Bin o e RBIRa- PO RDR OIS

4 Debug 2
v &¥ SimpleExample [Code Composer Studio - Device Debugging]

~ # Spectrum Digital DSK-EVM-eZdsp onboard USB Emulator/ TMS320C671X (Suspended - SW Breakpoint)
= main() at main.c:11 000000020
= c_int00() at boot.c:87 0xD0D0DCFE (the entry point was reached)

12. Click the Resume button at the top or press F8. Your code should now be running and the Debug

panel should say (Running).

13. Now, doing this every time you want to test some code can be a major pain. Instead, it is easier
to press the Suspend button or Alt+F8.

14. You can now make changes to your code as you see fit. Finally, press the Build button. Select Yes
to reloading the program automatically. It will be in the same state as step 11. Click Resume and
you are editing code again.



'+ workspace_v7 - CCS Debug - SimpleExample/main.c - Code Composer Studio

File Edit View Project Toels Run  Scripts  Window Help

N-HREe e BEYE - DER-S e inRiR DDt

%5 Debug 53 V=
v ¢ SimpleExample [Code Composer Studic - Device Debugging]
~ o Spectrum Digital DSK-EVM-eZdsp enboard USB Emulator/ TMS320C671X (Suspended - SW Breakpoint)
= main() at main.c:11 0x00000020
= c_intD0{) at boot.c:87 0xDDODOCFE (the entry point was reached)

[ main.c 52 | [g] hella.c [#] TMS320C6713.conml [ ] DSK6T13_wait{unsigned int) at dsk6713.c:189 3b4
* main.c

#define CHIP 6713

[V, T

& #include "dsk6713.h"|
7 #include "dsk6713_led.h"
g #include "dsk6713_flash.h”

void main(wveoid)
{
DSK6713_init();

DSK6713_LED init();

while (1)

DSK6713_LED_toggle(l);
D5K6713_waitusec(leaeana);

Frequently Asked Questions

e Where can | find necessary schematics, technical reference manuals, and other documentation
for the DSK?

o Everything can be found here: http://c6000.spectrumdigital.com/dsk6713/revc/

Additionally, some of these documents are contained in the docs directory of the ZIP file
provided with the project.
e How can | see what functions are available to use?
o Well, many of the traditional functions in the C language are available such as malloc,
free, printf, etc.

However, there are some special functions from the Board Support Library (BSL) that
was included. The API reference can be seen in the help file C6713DSK.chm located
inside the docs folder in the ZIP file provided with the project. Double-click the CHM file
and a menu will open.


http://c6000.spectrumdigital.com/dsk6713/revc/

This documentation is 10+ years older when CCS was at version 3.1 and thus some of
the information may not be applicable. However, the following sections contain
information regarding the BSL API:

BSL APl Index

BSL Board Setup API
BSL Codec API

BSL DIP Switch API
BSL Flash API

BSL LED API

Codec BSL Functions

E@ Help
=
Hide Back Pririt

Type in the keyword to find:

Eif-

Cptions

BSL API Index

|Board Support Library, BSL AP| Index

DSK6T13 init()

6713 DSK
Block Diagram
Board Description

Tutorial
Board Support Library
- _BSL AP Index

BSL Codec APl

BSL DIP Switch API

BSL Fash API

BSL LED APl

BSL Overview
Codec

Codec Overview
Codec Registers
Configuration Switches
CFLD
CPLD Owverview
CPLD Registers
Diagnostic Liility
Advanced Tests
Codec Test
Diagnostic Overview
DSP Test
General Tests
LED/Switch Test
Memory Diagnostic
DIP Switches

DIP Switch Overview
DSK Specific Files
Emor Messages
Examples

Device Driver Demos

DSK_App Example

Examples Overview

LED example

LEDPRD example

Tone example
Features
Flash

Flash BSL Functions

Flash Description
LEDPRD Example
LEDs

LED BSL Functions

LED Overview
Managing CDB Files

Board Support Library

BSL Board Setup AP

Codec BSL Functions

DIP Switch BSL Functions

2 DSK6713 rget()

DSK6713 rset()

DSK6713 version()

DSK6713 wait()

DSK6713 waitusec()

DSK6713 AIC23 openCodec()

DSK6&713 AIC
DSK6&T713 AIC
DSK6713 AIC
DSK6713 AICI3 write()
DSK6713 AICI3 rset)

23 closeCodec()
23
23
23
23
DSK6713 AIC23 rget()
23
23
23
23
23

confis()
read()

DSK6713 AIC23 outGain()
DSK6713 AIC23 loopback()
DSK6713 AIC23 mute()
DSK6713 AIC23 powerDown()
DSK6713 AIC23 setFreg)
DSK6713 DIP init()

DSK6713 DIP geti)
DSK6713 LED init()
DSK6713 LED off()
DSK6713 LED on(}
DSK6713 LED toggle()
DSK6713 FLASH checksum()
DSK6713 FLASH erase()
DSK6713 FLASH read()
DSK6713 FLASH write()

L

Display

Initialize the 6713 DSK

Read an 8-bit value from a CPLD register
Write an 8-bit value to a CPLD register

Get the DSK version

Spin in a software delay loop

Spin in a software delay loop (microseconds)

Allocate an identifying handle for an instance of a
codec

Release a codec handle

Set parameters on codec registers

Read 32 bits from the codec data stream
Write 32 bit value to the codec data stream
Set the value of a codec control register
Return the value of a codec register

Set the codec output gain

Enable/disable the codec loopback mode
Enable/disable the codec mute mode
Enable/disable the codec powerdown modes
Set the codec sample rate

Initialize the DIP switches

Read the DIP switches

Initialize the LED's

Turn specified LED off

Turn specified LED on

Toggle the specified LED

Calculate checksum for a range of memory
Erase a range of Flash memory

Read from a range of Flash memory

Write to a range of Flash memory



e | received error message “function _acos in file acos.c: invalid instruction schedule generated
o This is an odd message that happens the first time you build a project with CCS. If you
simple clean the project and try to rebuild it, the error message should disappear.



